// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m).*totaldisksize="(\d+(?:,\d+)*)".*"#).unwrap();
let string = "<drives name=\"drive 1\" deviceid=\"\\\\.\\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"136,7\">
<drives name=\"drive 1\" deviceid=\"\\\\.\\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"1367\">";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}