const regex = /.*totaldisksize="(\d+(?:,\d+)*)".*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*totaldisksize="(\\d+(?:,\\d+)*)".*', 'gm')
const str = `<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="136,7">
<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="1367">`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);