$re = '/.*totaldisksize="(\d+(?:,\d+)*)".*/m';
$str = '<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="136,7">
<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="1367">';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;