using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*totaldisksize=""(\d+(?:,\d+)*)"".*";
string substitution = @"$1";
string input = @"<drives name=""drive 1"" deviceid=""\\.\PHYSICALDRIVE0"" interface=""SCSI"" totaldisksize=""136,7"">
<drives name=""drive 1"" deviceid=""\\.\PHYSICALDRIVE0"" interface=""SCSI"" totaldisksize=""1367"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}