use strict;
my $str = '<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="136,7">
<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="1367">';
my $regex = qr/.*totaldisksize="(\d+(?:,\d+)*)".*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";