# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*totaldisksize=\"(\d+(?:,\d+)*)\".*"
test_str = ("<drives name=\"drive 1\" deviceid=\"\\\\.\\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"136,7\">\n"
"<drives name=\"drive 1\" deviceid=\"\\\\.\\PHYSICALDRIVE0\" interface=\"SCSI\" totaldisksize=\"1367\">")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.