re = /.*totaldisksize="(\d+(?:,\d+)*)".*/m
str = '<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="136,7">
<drives name="drive 1" deviceid="\\\\.\\PHYSICALDRIVE0" interface="SCSI" totaldisksize="1367">'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result