# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+|\w|\([^)]++\))/\1\n/gm;t' <<< "15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD"