#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+|\w|\([^)]++\))"
Local $sString = "15HGH" & @CRLF & _
"12ABCD" & @CRLF & _
"ABCD(Whatever)(test)" & @CRLF & _
"15HGH(Whatever)ASD"
Local $sSubst = "\1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)