const regex = /(\d+|\w|\([^)]++\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+|\\w|\\([^)]++\\))', 'gm')
const str = `15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD`;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);