$re = '/(\d+|\w|\([^)]++\))/m';
$str = '15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD';
$subst = "\1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;