import re
regex = re.compile(r"(\d+|\w|\([^)]++\))", flags=re.MULTILINE)
test_str = ("15HGH\n"
"12ABCD\n"
"ABCD(Whatever)(test)\n"
"15HGH(Whatever)ASD")
subst = "\\1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)