re = /(\d+|\w|\([^)]++\))/m
str = '15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD'
subst = '\\1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result