import Foundation
let pattern = #"(\d+|\w|\([^)]++\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)