package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+|\w|\([^)]++\))`)
var str = `15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD`
var substitution = "\1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}