using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+|\w|\([^)]++\))";
string substitution = @"\1\n";
string input = @"15HGH
12ABCD
ABCD(Whatever)(test)
15HGH(Whatever)ASD";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}