#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "href="x-msg:\/\/\d+\/""
Local $sString = "<base href="x-msg://1726/">"
Local $sSubst = "href="#""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)