const regex = /href="x-msg:\/\/\d+\/"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="x-msg:\\\/\\\/\\d+\\\/"', '')
const str = `<base href="x-msg://1726/">`;
const subst = `href="#"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);