re = /href="x-msg:\/\/\d+\/"/
str = '<base href="x-msg://1726/">'
subst = 'href="#"'
result = str.sub(re, subst)
# Print the result of the substitution
puts result