import Foundation
let pattern = #"href="x-msg:\/\/\d+\/""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<base href="x-msg://1726/">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"href="#""##
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}