package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`href="x-msg:\/\/\d+\/"`)
var str = []byte(`<base href="x-msg://1726/">`)
var substitution = []byte("href="#"")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}