using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""x-msg:\/\/\d+\/""";
string substitution = @"href=""#""";
string input = @"<base href=""x-msg://1726/"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}