use strict;
my $str = '<base href="x-msg://1726/">';
my $regex = qr/href="x-msg:\/\/\d+\/"/p;
my $subst = 'href="#"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";