$re = '/href="x-msg:\/\/\d+\/"/';
$str = '<base href="x-msg://1726/">';
$subst = "href=\"#\"";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;