// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href="x-msg:\/\/\d+\/""#).unwrap();
let string = "<base href=\"x-msg://1726/\">";
let substitution = "href=\"#\"";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}