# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^Redirect\h+301\h+(\S+)\h+(\S+)/rewrite ^$1\/?$ $2 permanent;/gm;t' <<< "Redirect 301 /comment/375 http://site.com/posts/c0a323fc07
Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d
"