#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^Redirect\h+301\h+(\S+)\h+(\S+)"
Local $sString = "Redirect 301 /comment/375 http://site.com/posts/c0a323fc07" & @CRLF & _
"Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d" & @CRLF & _
""
Local $sSubst = "rewrite ^$1/?$ $2 permanent;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)