$re = '/^Redirect\h+301\h+(\S+)\h+(\S+)/m';
$str = 'Redirect 301 /comment/375 http://site.com/posts/c0a323fc07
Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d
';
$subst = "rewrite ^$1/?$ $2 permanent;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;