# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Redirect\h+301\h+(\S+)\h+(\S+)"
test_str = ("Redirect 301 /comment/375 http://site.com/posts/c0a323fc07\n"
"Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d\n")
subst = "rewrite ^$1/?$ $2 permanent;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.