package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Redirect\h+301\h+(\S+)\h+(\S+)`)
var str = `Redirect 301 /comment/375 http://site.com/posts/c0a323fc07
Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d
`
var substitution = "rewrite ^$1/?$ $2 permanent;"
fmt.Println(re.ReplaceAllString(str, substitution))
}