use strict;
my $str = 'Redirect 301 /comment/375 http://site.com/posts/c0a323fc07
Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d
';
my $regex = qr/^Redirect\h+301\h+(\S+)\h+(\S+)/mp;
my $subst = 'rewrite ^$1/?$ $2 permanent;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";