import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Redirect\\h+301\\h+(\\S+)\\h+(\\S+)";
final String string = "Redirect 301 /comment/375 http://site.com/posts/c0a323fc07\n"
+ "Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d\n";
final String subst = "rewrite ^$1/?$ $2 permanent;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}