import Foundation
let pattern = #"^Redirect\h+301\h+(\S+)\h+(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Redirect 301 /comment/375 http://site.com/posts/c0a323fc07
Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"rewrite ^$1/?$ $2 permanent;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)