const regex = /^Redirect\h+301\h+(\S+)\h+(\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Redirect\\h+301\\h+(\\S+)\\h+(\\S+)', 'gm')
const str = `Redirect 301 /comment/375 http://site.com/posts/c0a323fc07
Redirect 301 /comment/2772 http://site.com/posts/76d68d4d9d
`;
const subst = `rewrite ^$1/?$ $2 permanent;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);