# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#([^#]+)#[^#]/<h1>\1<\/h1>/g;t' <<< "#test1 with
multiline headline#
##test2##
###test3###"