import Foundation
let pattern = ##"#([^#]+)#[^#]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
#test1 with
multiline headline#
##test2##
###test3###
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<h1>\1</h1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)