#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "#([^#]+)#[^#]"
Local $sString = "#test1 with" & @CRLF & _
"multiline headline#" & @CRLF & _
"##test2##" & @CRLF & _
"###test3###"
Local $sSubst = "<h1>\1</h1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)