using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#([^#]+)#[^#]";
string substitution = @"<h1>\1</h1>";
string input = @"#test1 with
multiline headline#
##test2##
###test3###";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}