use strict;
my $str = '#test1 with
multiline headline#
##test2##
###test3###';
my $regex = qr/#([^#]+)#[^#]/p;
my $subst = '<h1>\\1</h1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";