import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#([^#]+)#[^#]";
final String string = "#test1 with\n"
+ "multiline headline#\n"
+ "##test2##\n"
+ "###test3###";
final String subst = "<h1>\\1</h1>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}