$re = '/#([^#]+)#[^#]/';
$str = '#test1 with
multiline headline#
##test2##
###test3###';
$subst = "<h1>\1</h1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;