import re
regex = re.compile(r"#([^#]+)#[^#]")
test_str = ("#test1 with\n"
"multiline headline#\n"
"##test2##\n"
"###test3###")
subst = "<h1>\\1</h1>"
result = regex.sub(subst, test_str)
if result:
print(result)