# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)/\g<degrees> \g<decimal_minutes>/gm;t' <<< "-7045.886002
7203.23423
11023.2343
-17323.2343
"