package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)`)
var str = `-7045.886002
7203.23423
11023.2343
-17323.2343
`
var substitution = "\g<degrees> \g<decimal_minutes>"
fmt.Println(re.ReplaceAllString(str, substitution))
}