#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)"
Local $sString = "-7045.886002" & @CRLF & _
"7203.23423" & @CRLF & _
"11023.2343" & @CRLF & _
"-17323.2343" & @CRLF & _
""
Local $sSubst = "\g<degrees> \g<decimal_minutes>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)