use strict;
my $str = '-7045.886002
7203.23423
11023.2343
-17323.2343
';
my $regex = qr/^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)/mp;
my $subst = '\\g<degrees> \\g<decimal_minutes>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";