import Foundation
let pattern = #"^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-7045.886002
7203.23423
11023.2343
-17323.2343
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<degrees> \g<decimal_minutes>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)