# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n/$1/g;t' <<< "\nnew\"test\naaaa\\\n\"\nta\n`this is a \nnewline that should be kept`\n'this is a \nnew test'\n
Have a look at \"\\\n\""