import Foundation
let pattern = #"("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\nnew"test\naaaa\\\n"\nta\n`this is a \nnewline that should be kept`\n'this is a \nnew test'\n
Have a look at "\\\n"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)