using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""\\]*(?:\\.[^""\\]*)*""|'[^'\\]*(?:\\.[^'\\]*)*'|`[^`\\]*(?:\\.[^`\\]*)*`)|\\n";
string substitution = @"$1";
string input = @"\nnew""test\naaaa\\\n""\nta\n`this is a \nnewline that should be kept`\n'this is a \nnew test'\n
Have a look at ""\\\n""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}